Follow

NROC Course Library End User System Requirements

As a general rule, we test and support NROC courses and tools in the latest version of all modern browsers and operating systems, minus one. (For example, if the latest version of a browser or operating system is v10, we test in -- and provide support for -- v10 and v9, but not v8 or lower.)

  • Operating System: Microsoft® Windows® 8.1 or higher (for Windows users) or Mac OS X v10.11 or v10.12 (for Mac users). iOS devices (e.g., iPads) are supported as well.
  • Browser: Internet Explorer 11.0 or Edge, Mozilla Firefox 50.0 or later, Google Chrome, Safari 9.0 or later.
  • Internet Connection: A high-speed Internet connection such as DSL or Cable Modem is highly recommended.

We do not support the following systems:

  • Internet Explorer 11 (IE 11) when used with Windows 10. Please use the default Windows 10 browser, Edge.
  • Acer C710-2487 (Manufactured in 2013)

 

 

Technical Support

Technical support is provided to active NROC Members. A Knowledge Base is provided that will answer most technical issues and a ticket system is available for additional support.

Technical support will only apply to issues involving the NROC Library and does not include support for hardware, network, operating system or computer issues related to the member’s LMS.

 

 

201710



Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk